• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Outside the recent fun from our Terminator

#1
Hello Smile
Outside the recent fun from our Terminator, I would like to ask what would be the fate CI 3.2 branch. Wouldn't it be better if some new features there to backported to CI 3.1? I think that nobody would be interested about CI 3 with a BC break.

Also, maybe for CI 3 minimal required version of PHP might be bumped up - 5.5 or 5.6. There is no point about maintainig compatibility-layer code and wasting time and strength for too old and insecure servers.
Reply

#2
We must understand semantic versioning differently because a minor change such as 3.1 to 3.2 indicates there is no backward compatibility break.

While I agree that nobody is interested in CI 3 with a BC break, that might not be possible in consideration of which versions of PHP are actively supported. It seems a disservice to the world's developers to supply a framework with a backbone (PHP) using obsolete and vulnerable code. But making PHP v7.3 or greater a requirement would almost certainly break something for many (most?) existing CI v3 based apps.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.