• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Form-Action Variables not working while routing

#1
Question 
Hi everyone,
it looks like my CI4 does not process form variables.

I have a very simple form with an action to "/login/" for example.

goes like this:
helper(['form', 'url']);
echo form_open('/login/user_login_process/');
echo form_input("eingabezeile", "eingabezeile");
echo form_close();

If I push the form button, the form fields are not available in the action-controller.
In my action-controller it allways says:
echo $_SERVER['REQUEST_METHOD']; --> "get".
And none of these work: $variable = $this->request->getPost("formfieldname"); doesnt give the value I entered.

I dont see the forest in front of the trees, as we say in german...

Thanks for a tip!
ME.
Reply

#2
You need to add your form submit button before form_close()

PHP Code:
echo form_open('/action_route');
echo 
form_input('input_name''input_value');
echo 
form_submit('submit_name''submit_value');
echo 
form_close(); 
Reply

#3
You must set `method="post"` in your form.
If it is not set, then form sends data with GET.
And you are trying to get data from POST - $this->request->getPost("formfieldname")
Reply

#4
It now works, probably one of those two things was not correct.
Thank you for your immediate support!!!
ME
Reply

#5
(10-20-2020, 01:55 AM)T.O.M. Wrote: You must set `method="post"` in your form.
If it is not set, then form sends data with GET.
And you are trying to get data from POST - $this->request->getPost("formfieldname")

form_open() appears to default to POST according to the documentation: https://codeigniter.com/user_guide/helpe...#form_open.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.