Welcome Guest, Not a member yet? Register   Sign In
PHP 8.1
#1

Ci4 fully support current PHP version (8.1)>
Reply
#2

i'm on Arch Linux and have :

[[email protected]:~]$ php --version (10-30 10:48)
PHP 8.0.12 (cli) (built: Oct 20 2021 16:06:03) ( NTS )
Copyright © The PHP Group
Zend Engine v4.0.12, Copyright © Zend Technologies
[[email protected]:~]$ (10-30 10:48)

i'm using 4.1.4 Ci and everything fine - i thought Arch Linux was pretty cutting edge , where are you using 8.1 ?
Reply
#3

No, not yet.
Reply
#4

8.1 is not even released yet. Current version is 8.0.
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
/*** NO support in private message - Use the forum! ***/
Reply
#5

available soon on 25 November 2021
Reply
#6

Almost there.

All tests except "PHP 8.1 - Postgre" passed.
See https://github.com/codeigniter4/CodeIgni...883/checks
Reply
#7

Now all green!

Add support for PHP 8.1 by paulbalandan · Pull Request #4883 · codeigniter4/CodeIgniter4
https://github.com/codeigniter4/CodeIgni...883/checks
Reply
#8

Good work! The same day the official 8.1 is released! Smile
https://www.php.net/releases/8.1/en.php
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
/*** NO support in private message - Use the forum! ***/
Reply
#9

Good work! Thanks !
Reply
#10

(10-28-2021, 11:13 AM)etShops Wrote: Ci4 fully support current PHP version (8.1)>

yup! Waiting for some new features to arrive.
Reply




Theme © iAndrew 2016 - Forum software by © MyBB