• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I have integrated a new version CI based on CI 1.6.1.

#1
[eluser]chmod[/eluser]
I use the following plugins:
1:adodb 5 (which can connect more than one database ,though the db type is different.)
2:fckeditor 2.6 (which can allow you create a editor,strong and easy...)
4:enable $_GET (because CI disable $_GET,but when you get data from another website which use get...,now you can GET...)
5:Smarty 2.6 (option)
...
Is it useful ?

#2
[eluser]xwero[/eluser]
1 you can do the same with CI
2 not everyone wants/needs to use a wysiwyg editor
3 ???
4 you have to change the config setting to use GET

I'm not sure where you are going with this topic. Are you suggesting you created a fork based on a few (unnecessary) changes and optional additions?

If every developer would distribute his modified CI i guess there will be thousands.

#3
[eluser]Bramme[/eluser]
[quote author="xwero" date="1212666799"]1 you can do the same with CI
2 not everyone wants/needs to use a wysiwyg editor
3 ???
4 you have to change the config setting to use GET

I'm not sure where you are going with this topic. Are you suggesting you created a fork based on a few (unnecessary) changes and optional additions?

If every developer would distribute his modified CI i guess there will be thousands.[/quote]Gotta agree on this one...

For example, personally, I'm a fan of tinymce, not fckeditor. Why whould you use $_GET, just use the $this->segment or whatever the function is.
And as for Smarty: CI has a templating function...

#4
[eluser]Michael Wales[/eluser]
Quote:If every developer would distribute his modified CI i guess there will be thousands.

Completely agree. It doesn't sound like you integrated a new version, it sounds like you just tossed a few libraries in there. I'm pretty sure every developer does this - I personally hate to look at a clean install of CI without all of my helpers and libraries.

#5
[eluser]chmod[/eluser]
I don't think so.
perhaps some one needn't above libs.
but when some use one of these libs,he must google or search in CI's forum/WIKI.
I cost many time and try more than once to debug these libs.so if CI can integrate these libs by itself,and if some one use one of these,he/she can quickly load it,no need cost time to integrate them. Isn't it a good idea?

yes,CI can enable $_GET,but if you enable it ,uri helper is not used. The CI's author said it on another thread.
CI can connect muti db ?I try many times,no sucess. Why?because it always connect the DEFAULT config.So I decided to integrate adodb to it. the result is you can connect any dbs and any type.

#6
[eluser]xwero[/eluser]
There is no problem if you change the settings (enable_query_strings TRUE, uri_protocol PATHINFO) with the uri helper

You can put the database configuration for different databases in the config/database.php file or you can create an array with the configuration and add it to the load->database method.
It's not because you can't get it to work it doesn't function. If it doesn't function it wouldn't be in the framework.

If you create a fork it would have more to offer then a few changes. You better release the libraries and let the developers decide if they are going to add it in their CI modification.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.