• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeExtinguisher 2.0 Release Candidate 14.2

[eluser]got 2 doodle[/eluser]
Hello Hazy

try changing line 21 of plugins/image.php

Code:
include_once(APPPATH.'/plugins/file.php');  /* old code = include_once("file.php"); */

This error has popped up before, I'm not sure why it hasn't been fixed.

I hope this helps
doodle

[eluser]hazy[/eluser]
Fixed many thanks doodle :-)

[eluser]Palino[/eluser]
hello jTaby & CI friends,

im playing with CI and CE over 2 months -> great job for both.

Right now i stopped here (CE 14.2):
my controller for articles administration is showing all the data. I need to show only articles where language_id is specified. Is something like this planned (custom SQL addon for example). I know, that there is some search function which can filter data, but i need to filter it by default...

Thanks for your hints.

Pali

[eluser]Majd Taby[/eluser]
Palino, you want to specify a table_access_restriction.

[eluser]matthewr[/eluser]
Hi Jtaby,

I really need the answers to these questions, if you have time, please answer them.

1. Even if a delete the Example table, whenever i login it redirects to the Example page. This is very annoying. How do i change this?

2. How do I get rid of the View Modes: and Themes: options at the bottom. I do not want my user to be able to select his theme or view mode.

3. How do I get rid of that specify permissions for this item link?

Thanks

[eluser]Majd Taby[/eluser]
1) change your default_controller in routes.php

2 and 3) remove them from the view. You remove view modes from views/view_modes/table.php and then to remove permissions, go to controllers/codexcontroller.php and search for $data['permissions_form'] = blahblahblah and change it to $data['permissions_form'] = '';

[eluser]matthewr[/eluser]
Awesome thanks!

[eluser]Thoer[/eluser]
I'm using the encrypt_name property of the Image plugin and I found out that creating thumbnails fails, because the prepForDb function guesses the name of the source image for the thumbnail from the uploaded filename instead of the actual name. You should change at least one line in plugins/Image.php to fix this:
Code:
$config['source_image']    = $path.$uploaded_file_name; // old code: $config['source_image']    = $source_file;

[eluser]Unknown[/eluser]
Any plans to support Postgresql?

[eluser]unsub[/eluser]
Hello
I am having a strange error in the table view:
I have a database table that has records of things from up to 300 years ago; Strangely, in the tabular view of the Codex installation, any date from before 1900 is displayed as Dec 31, 1969... huh... interesting date, to be sure, but not the correct one Smile

So first my system: PHP 4 (sigh...) on a unix server, I think it's redhat, but our company just switched our main servers so I could be wrong. Not windows, and not solaris... sorry I can't be more specific.

Here's what I have tried:
it seems the table view is using js files from the assets folder to draw out the contents of the db, and so I went to the two different date entries and just had the functions returning their arguments unaltered, as a test to see what the heck was going on in all that javascript. But I still got the medium form dates, and the pre-1900 ones were still dec 31, 1969

I hope i described that in a somewhat understandable fashion.

Thanks for all your awsome work!!
Smile
Gabriel


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.