Search Results
Post Author Forum Replies Views Posted [asc]
    Thread: Email Class TLS 587 SASL ERROR
Post: RE: Email Class TLS 587 SASL ERROR

hmm.. SMTP works if I just switch to: 'protocol' => 'mail', ??
dbrooke General Help 2 724 05-27-2020, 10:01 PM
    Thread: Email Class TLS 587 SASL ERROR
Post: Email Class TLS 587 SASL ERROR

Codeigniter 3 Hello, seems I always have problems with CI and email. I run a properly configured Postfix / Ubuntu email server. I have several apps that authenticate via TLS port 587, with a valid ...
dbrooke General Help 2 724 05-27-2020, 05:48 PM
    Thread: Upgrading - Incremental or All at once?
Post: RE: Upgrading - Incremental or All at once?

After doing this, and with all presumed disclaimers ;-), it is really straight forward to just go straight to 3.1.11. Use a custom index.php (as the docs say) ie. In general, you can overwrite 'syst...
dbrooke Installation & Setup 4 1,399 02-25-2020, 08:07 PM
    Thread: Upgrading - Incremental or All at once?
Post: RE: Upgrading - Incremental or All at once?

(02-20-2020, 12:55 PM)jreklund Wrote: You should replace your system folder with the latest version. And then follow all steps and replacing your files in application and doing the modifications. H...
dbrooke Installation & Setup 4 1,399 02-24-2020, 07:40 AM
    Thread: Upgrading - Incremental or All at once?
Post: Upgrading - Incremental or All at once?

Hello, In prepping for my upgrades from 3.1.0.. I'm looking at about 11 versions that I need to step through ( don't ask why I didn't do the step upgrades ). Re: https://codeigniter.com/user_guide...
dbrooke Installation & Setup 4 1,399 02-20-2020, 12:22 PM
    Thread: Force SSL for the site
Post: RE: Force SSL for the site

(02-18-2020, 09:40 AM)Mekaboo Wrote: Thank ya kindly  :heart: I have a Cpanel (HostGator)...will look into that later on as well as changing things within the config file. Thanks again!!! It's in ...
dbrooke General Help 6 1,968 02-19-2020, 09:51 AM
    Thread: Force SSL for the site
Post: RE: Force SSL for the site

Hi, what platform? cPanel has this kind of redirect built in. Could also force HTTPS in .htacess (which you can google). Make sure to set your $config['base_url'] in application/config/config.ph...
dbrooke General Help 6 1,968 02-18-2020, 09:35 AM
    Thread: sanitize textarea input for database insertion - best practice
Post: RE: sanitize textarea input for database insertion...

Thx for the feedback. Below seems to work fairly well. @InsiteFX.. I threw your code into my helper file. Thx. So here is what I have: Controller: - Validate: Code:$this->form_validation->...
dbrooke General Help 3 3,443 06-27-2019, 08:58 AM
    Thread: sanitize textarea input for database insertion - best practice
Post: sanitize textarea input for database insertion - b...

Hello, I thought I'd start this thread after a pretty thorough effort of searching / reading. My Situation I have a simple textarea that users are copy/pasting blocks of "text" (mostly from MS Word...
dbrooke General Help 3 3,443 06-26-2019, 01:22 PM
    Thread: Authorize.Net (net\authorize\api) Helper
Post: RE: Authorize.Net (net\authorize\api) Helper

Here is a (very) brief overview of what I did to implement the basic charge CC sample code located here: https://github.com/AuthorizeNet/sample-c...t-card.php This should be a good compass to use in ...
dbrooke Libraries & Helpers 1 2,014 12-03-2018, 01:39 PM
    Thread: Authorize.Net (net\authorize\api) Helper
Post: Authorize.Net (net\authorize\api) Helper

Hello CI patrons. I am just starting an integration for the latest Authorize.Net PHP SDK.  I couldn't find an example for the newer net\authorize\api method, so I thought I'd start the thread here....
dbrooke Libraries & Helpers 1 2,014 11-29-2018, 12:10 PM
    Thread: [solved] allow query string (?p=) to one directory only
Post: RE: allow query string (?p=) to one directory only

I solved this in config.php by doing: $config['enable_query_strings'] = FALSE; and $config['permitted_uri_chars'] = 'a-z 0-9~%.:_\&\=\-'; Then editing the .htaccess file for the app tha...
dbrooke General Help 3 2,664 05-02-2017, 07:51 AM
    Thread: [solved] allow query string (?p=) to one directory only
Post: RE: allow query string (?p=) to one directory only

Strange thing.. if I change one character of that first URL, it works fine.. it's the '&' char. before 'remote': domain.com/daforum/index.php?p=/?remote=http%3A%2F%2Fdomain.com%2Fforum%2F&loc...
dbrooke General Help 3 2,664 04-28-2017, 04:37 PM
    Thread: [solved] allow query string (?p=) to one directory only
Post: RE: allow query string (?p=) to one directory only

FYI, this is an example of a call that is generated by the app that returns a 404: http://domain.com/daforum/index.php?p=/&...%2F&locale= The same call without the query string: http://domain...
dbrooke General Help 3 2,664 04-28-2017, 03:47 PM
    Thread: [solved] allow query string (?p=) to one directory only
Post: [solved] allow query string (?p=) to one directory...

Hello CI'ers, I'm trying to embed a forum app into a codeigniter page. The problem I am running into is that the app is producing tradition query string calls which CI is not allowing.. ie. I get a 40...
dbrooke General Help 3 2,664 04-28-2017, 03:34 PM
    Thread: session & multi subdomains
Post: RE: session & multi subdomains

(03-16-2017, 08:18 AM)pws Wrote: hello, please can gve me full example? Please share the URL of both sites that you are dealing with.. thx. Donovan
dbrooke General Help 3 1,818 03-16-2017, 09:09 AM
    Thread: How best to Display an optional modal page
Post: RE: How best to Display an optional modal page

Not to be confused with 'Model'... Sounds good to me.. pretty straight forward to do stuff based off of cookie info. Did you try it? bootstrap has a pretty good Model that can be enacted easily.
dbrooke General Help 1 1,188 03-16-2017, 08:23 AM
    Thread: session & multi subdomains
Post: RE: session & multi subdomains

You have a limit set on your cookie domain path most likely.. look in the docs how to set the cookie path and set it to 'domain.com' rather than 'www.domain.com' or 'blog.domain.com'. Donovan
dbrooke General Help 3 1,818 03-16-2017, 08:07 AM
    Thread: Blank URI parameters
Post: RE: Blank URI parameters

No comments I guess?? I guess I'll start adding dummy fillers for any param that doesn't have a value.
dbrooke General Help 2 1,408 03-16-2017, 08:00 AM
    Thread: Blank URI parameters
Post: RE: Blank URI parameters

FYI, upon running more tests, in the call that doesn't work, it is clear that $subaction is being set to 254. That seems odd to me.. but maybe someone can explain a best practice here??
dbrooke General Help 2 1,408 03-15-2017, 12:09 PM

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.