Welcome Guest, Not a member yet? Register   Sign In
Can't get a view to load

[quote author="TWP Marketing" date="1342736062"]another point, using a subview like your footer means that the rest of the html code is missing, hence a blank screen. Is the verify page a full html document, with html header data?[/quote]

Good idea - I replaced the contents of my vVerifyError file with just a standard HTML5 page template. Still get a blank page. Sad

[eluser]TWP Marketing[/eluser]
CI doesn't have a native log system, unless you wrote it yourself. PHP and the server are usually sufficient for debugging.
Re my previous: is your verify page view a complete html document or only a sub section?

Does your view actually have something in it? Is it valid HTML, not being hidden by poor HTML either in the view or elsewhere?

CI would throw an error if it could not find the view file. It's likely a problem with the actual output of the file.

Here is my vVerifyError page:

<!DOCTYPE html>
&lt;html lang="en"&gt;
&lt;meta charset="utf-8"&gt;
&lt;title&gt;Welcome to CodeIgniter&lt;/title&gt;


<h1>Welcome to CodeIgniter!</h1>

Just a standard page template (cut from the welcome_message.php file)

OK, I'm getting something to show up now...

A few lines below that if block was an exit() statement. Removing that lets the page display.

I didn't include that earlier since it was outside the if block. Sorry Sad

[eluser]TWP Marketing[/eluser]
Hmmm, I'm stumped. It should (in quotes) display. The loader class is automatically loaded, and other pages are working, so the problem is elsewhere. The verify page itself works outside of this controller function. Another view fails in a similar manner when called using this code. I don't think it is the actual code on the verify page, but can't check that from here.

Perhaps someone else has a suggestion?

Output runs after the controller. If you exit in the controller, the script stops completely. Now you know. Smile

[eluser]TWP Marketing[/eluser]
aha, and I needed typing practice. So the page was probably displaying and then the exit() killed everything. Solved?

/forehead slap

Yeah, now I know.

Wow, that was a tough one. Sorry to waste everyone's time Sad


[eluser]TWP Marketing[/eluser]
Not a problem. I learned something too.

Theme © iAndrew 2016 - Forum software by © MyBB