Welcome Guest, Not a member yet? Register   Sign In
CI Documentation Tutorial - problem with removing 'index.php' from url, when create News


I have a question about remove 'index.php' from url. I used Tutorial from Documentation, change my .htaccess file by Documentation. There is all right, but...

When I start http://mysite.com/news/create and post new news - there is redirecting to http://mysite.com/index.php/news/create... but I think, it should be http://mysite.com/news/create.

Maybe, it happening, because my app and sys folder placed out public site folder? Out folder 'www'.

.application/config/config.php - leave this blank.
$config['index_page'] = '';

index.php - for application and system folders outside of it.
$system_path = '../system';
$application_folder = '../application';

.htaccess - my .htaccess file.
<IfModule mod_rewrite.c>

# pass the default character set
AddDefaultCharset utf-8

    # Make sure directory listing is disabled
Options +FollowSymLinks -Indexes
RewriteEngine on

# NOTICE: If you get a 404 play with combinations of the following commented out lines
#AllowOverride All
RewriteBase /

# Restrict your site to only one domain
# !important USE ONLY ONE OPTION

# Option 1: To rewrite "www.domain.com -> domain.com" uncomment the following lines.
#RewriteCond %{HTTPS} !=on
#RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
#RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

# Option 2: To rewrite "domain.com -> www.domain.com" uncomment the following lines.
#RewriteCond %{HTTPS} !=on
#RewriteCond %{HTTP_HOST} !^www\..+$ [NC]
#RewriteCond %{HTTP_HOST} (.+)$ [NC]
#RewriteRule ^(.*)$ http://www.%1/$1 [R=301,L]

# Remove index.php from URL
RewriteCond %{HTTP:X-Requested-With} !^XMLHttpRequest$
RewriteCond %{THE_REQUEST}   ^[^/]*/index\.php [NC]
RewriteRule ^index\.php(.*)$   $1 [R=301,NS,L]

# Send request via index.php (again, not if its a real file or folder)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

# deal with php5-cgi first
<IfModule mod_fcgid.c>
  RewriteRule ^(.*)$ index.php?/$1 [QSA,L]

<IfModule !mod_fcgid.c>

  # for normal Apache installations
  <IfModule mod_php5.c>
   RewriteRule ^(.*)$ index.php/$1 [QSA,L]

  # for Apache FGCI installations
  <IfModule !mod_php5.c>
   RewriteRule ^(.*)$ index.php?/$1 [QSA,L]




You are brilliant! It is a error in my config.php

$config['index_page'] = 'index.php';

I should use $config['index_page'] = '';

because (it is comment in config.php):

...If you are using mod_rewrite to remove the page set this variable so that it is blank.

Thank you so much!

Your very welcome.

Theme © iAndrew 2016 - Forum software by © MyBB