• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Get URI segment returns nothing.... [RESOLVED]

#1
[eluser]Frychiko[/eluser]
Hi,

I started using CI yesterday to convert over an online price comparison shop, anyway this problem stopped me dead in my tracks.

I have an URL:

Code:
http://localhost/ci/manufacturer/edit/10

* manufacturer is my controller
* edit is a function within the manufacturer controller

I want to get a URI segment within the edit function with:

Code:
$this->uri->segment(n)

ie.

Code:
function edit() {
   echo "segment:".$this->uri->segment(3);
}

I tried 'n' with values from 0-3 but nothing is returned.

Perhaps I'm missing a configuration setting or something?

cheers,
Frychiko


Messages In This Thread
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 09:17 AM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 10:40 AM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 10:49 AM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 01:47 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 01:50 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 01:53 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 05:25 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 05:27 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 05:34 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 06:00 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-30-2008, 06:11 PM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-31-2008, 12:41 AM
Get URI segment returns nothing.... [RESOLVED] - by El Forum - 07-31-2008, 01:00 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.