• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Display Above Root Image with a controller on CI3-RC2

#8
(02-10-2015, 09:42 AM)Narf Wrote:
(02-10-2015, 09:38 AM)Mel9pr Wrote:
(02-10-2015, 02:14 AM)Narf Wrote: I told you to remove it because it's wrong regardless of the problem that you're having - get_instance() gets an instance of your controller, and you're calling it from that same controller's constructor, which in turn is the place where a lot of stuff is loaded, so it made sense that it could break something.

Thank you for let me kow that.

However I don't believe this is a browser issue. I try with three different browsers and there is no difference. As I mentioned before this not happens with CI3 previews version using the Session_native.php driver. It seems to be something on CI3-RC2 session improvements. Or a PHP bug inadvertently exposed.

I'm not saying it's a browser issue, I'm saying that's how a browser probably behaves. Smile

Previous CI3-dev versions didn't enforce strict mode sessions, so that might explain it ... Either way, look at the request headers.

http://localhost/codeIgniter-3.0.2/gallery

GET /codeIgniter-3.0.2/gallery HTTP/1.1
Host: localhost
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Referer: http://localhost/codeIgniter-3.0.2/gallery
Connection: keep-alive

HTTP/1.1 200 OK
Date: Tue, 10 Feb 2015 18:01:21 GMT
Server: Apache/2.4.10 (Unix) OpenSSL/1.0.1j PHP/5.6.3 mod_perl/2.0.8-dev Perl/v5.16.3
X-Powered-By: Codeigniter 3.0
Set-Cookie: ci_session=d2d2928f325c62dcce7ec9298907c38aef7f80f0; path=/; secure; HttpOnly
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Last-Modified: Tue, 10 Feb 2015 17:01:21 GMT
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html; charset=UTF-8

I try setting the ini_set('session.use_strict_mode', 1); to 0 but nothing changes,
I change the Cache-Control to public but nothing changes,
I remove the Pragma: no-cache but nothing changes,

Man this thing is a hard one!

Any way... if the session folder is overwhelm with too much session files....
Do I need to worry about server performance or session security issues?
Do you think this behavior will cause some security concerns?
Reply


Messages In This Thread
RE: Display Above Root Image with a controller on CI3-RC2 - by Mel9pr - 02-10-2015, 10:18 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.