• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BUG when using JOIN, DBPREFIX and database ALIAS?!?!

#1
[eluser]Unknown[/eluser]
Hello,

In CI 1.7.1, using a dbprefix (for example "dot_")in ./application/config/database.php, and setting aliases for the tables, the following code is producing a malformed query.

Code:
$this->db->select('d.company, a.activity');
$this->db->join('activities a', 'a.activity_id = d.company_id', 'left');
$this->db->get('directory d', 10);

Generates:

Code:
SELECT `d`.`company`, `a`.`activity` FROM (`dot_directory` d) LEFT JOIN `dot_activities` a ON `a`.`activity_id` = `dot_d`.`company_id` LIMIT 10

Expected:

Code:
SELECT `d`.`company`, `a`.`activity` FROM (`dot_directory` d) LEFT JOIN `dot_activities` a ON `a`.`activity_id` = `d`.`company_id` LIMIT 10

I believe there is a problem with method the _track_aliases in the CI_DB_active_record class, because it is not aware of the fact that table used in method get() has also an alias.

If this was reported before I am sorry, but I searched the forum and did not found this problem reported before.

Thanks!


Messages In This Thread
BUG when using JOIN, DBPREFIX and database ALIAS?!?! - by El Forum - 08-19-2009, 02:02 AM
BUG when using JOIN, DBPREFIX and database ALIAS?!?! - by El Forum - 06-17-2011, 09:23 AM
BUG when using JOIN, DBPREFIX and database ALIAS?!?! - by El Forum - 06-20-2011, 04:52 AM
BUG when using JOIN, DBPREFIX and database ALIAS?!?! - by El Forum - 06-20-2011, 07:01 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.