Should I use version 2?

#6
[eluser]peredurabefrog[/eluser]
[quote author="Phil Sturgeon" date="1292099415"]peredurabefrog: CI is just PHP, so you can use any PHP 5 features you like. Autoload your libraries, have static libraries, use callbacks and closures in your controllers, etc.

As for whether you should use 1.x or 2.x, do it. If you write 1.7.x code now you'll only have to change it later. Besides, every bug found in the 1.7.x branch is fixed in the 2.x branch. Thanks to that I find this branch to be much more stable, even if it is labeled as "in development". I wrote up my opinions in an article which explains things a bit more.

http://philsturgeon.co.uk/news/2010/10/c...-is-stable[/quote]

Hi,

Thanks to you and Michalsn for your kind replies. I'm reassured.

Cheers


Peredur


Messages In This Thread
Should I use version 2? - by El Forum - 12-11-2010, 05:44 AM
Should I use version 2? - by El Forum - 12-11-2010, 06:05 AM
Should I use version 2? - by El Forum - 12-11-2010, 06:30 AM
Should I use version 2? - by El Forum - 12-11-2010, 08:03 AM
Should I use version 2? - by El Forum - 12-11-2010, 08:30 AM
Should I use version 2? - by El Forum - 12-11-2010, 10:57 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.