• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is it okay to use require_once for libraries which aren't CI 'compatible'?

#11
[eluser]Matalina[/eluser]
Libraries must be classes in a specific form: http://ellislab.com/codeigniter/user-gui...aries.html

Helpers on the other hand are not in a class and can just be functions.

Libraries do not have to extend core classes.

Simple_html_dom is not a class it's a bunch of functions, because it's not a class it's basically a helper which means it's called with out the scopes. I amend that. It contains classes but a library can be only a class.



Messages In This Thread
Is it okay to use require_once for libraries which aren't CI 'compatible'? - by El Forum - 03-02-2012, 03:42 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.