Welcome Guest, Not a member yet? Register   Sign In
Just installed CI4 RC1 but getting blank pages

did you get a fix for the zlib.output_compression = on issue?

I have the exact same issue. Fresh install, windows/xampp, i have other sites working on CI 3. This was a fresh install with composer (done yesterday), error log just shows home controller loaded, blank page.

if i remove:

while (\ob_get_level() > 0)

\ob_start(function ($buffer) {
return $buffer;

from events.php it works, with code back in blank page.

I have just been facing this exact problem.

I am using shared hosting using cPanel.

In my system, there is an option to turn OFF zlib.output_compression and when I do that, it goes from only delivering blank pages, to fully rendered website.

The headers all show a completely good transfer return code 200, all looks good, but there is no payload in the transfer.

I would suggest that this is therefore, still a real world problem.

I faced the same problemalso after transferring the files to the server. The problem was solved after I ran 'composer update' while at the project root

Theme © iAndrew 2016 - Forum software by © MyBB