Welcome Guest, Not a member yet? Register   Sign In
[SOLVED, kind of] phpMyAdmin refuses to create table, claims it exists

Hi everybody,
I tried to create a new table (called users) in my database using phpMyAdmin, and it comes back saying a table with that name already exists, but it doesn't
I even tried creating a new database, and tried creating the same table, and got the same error

I can create tables with other names
I've also tried restarting MySQL/Apache but no luck

Here's what phpMyAdmin comes back with

SQL query:

CREATE TABLE `project_trackr`.`users` (
`id` INT( 32 ) NOT NULL ,
`first_name` VARCHAR( 64 ) NOT NULL ,
`last_name` VARCHAR( 64 ) NOT NULL ,
`email` VARCHAR( 255 ) NOT NULL ,
`password` VARCHAR( 32 ) NOT NULL ,
`created_on` DATETIME NULL ,
`updated_on` DATETIME NULL ,
`accessed_on` DATETIME NULL ,
PRIMARY KEY ( `id` )

MySQL said: Documentation
#1050 - Table 'users' already exists

Anyone come accross something like this, and know how to solve it?

Any help is greatly appreciated

Update: I've also tried creating the users table manually using SQL, and using the CI DB forge class, but both methods failed Sad

A hosting issue, maybe? Dementia? Maybe the error is wrong... could it be a permissions issue?

[eluser]Thorpe Obazee[/eluser]
[quote author="slowgary" date="1240808050"]A hosting issue, maybe? Dementia? Maybe the error is wrong... could it be a permissions issue?[/quote]

I'll vote for Dementia :p

Have you started MySQL with the --ndbcluster option? Others on the web have reported having the same problem using this option, as it does not allow the creation of new tables. That wouldn't explain though why you can create other tables, just not `user`.

Its not a hosting issue, as I'm running this on localhost using XAMPP
And I've never seen this problem in 5+ years of dev/MySQL/phpMyAdmin

And I'm pretty sure its not demntia either Tongue

Have you tried clearing your browsers cache, and using a different browser?

Also, you might want to grab yourself a copy of [url="http://dev.mysql.com/downloads/gui-tools/5.0.html"]MySQL Administrator[/url] and see if that makes anything clearer.

@TheFuzzyOne: I tried it in Firefox and IE7, and it had the same problem (I didn't expect it to make a difference, as it failed creating it from SQL and DBForge (via CI)

The problem seemed to have somehow resolved itself, and I was able to create the table on another machine (I have Dropbox sync the htdocs and SQL folders in XAMPP between multiple machines, which has worked flawlessly for as long as I can remember)

Theme © iAndrew 2016 - Forum software by © MyBB