• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tutorial error...?? (RESOLVED)

#2
[eluser]Aken[/eluser]
What's the URL of the page giving you the 404 error? You can use example.com instead of your live domain.

A couple things you can try:

1) Load the URL helper to your controller constructor, and use the site_url() function to help generate the news slug URL.
Code:
// In News __construct():
$this->load->helper('url');

// Replace your link URL with:
<?php echo site_url('news/' . $news_item['slug']); ?>

2) In your controller's view() method, replace show_404() with something like
Code:
exit('The error is here.');
If your browser then displays the error message instead of CI's 404 page, then you know your model isn't returning the data it's expected to.


Messages In This Thread
Tutorial error...?? (RESOLVED) - by El Forum - 01-23-2012, 05:03 PM
Tutorial error...?? (RESOLVED) - by El Forum - 01-23-2012, 07:41 PM
Tutorial error...?? (RESOLVED) - by El Forum - 01-24-2012, 09:56 AM
Tutorial error...?? (RESOLVED) - by El Forum - 01-24-2012, 05:26 PM
Tutorial error...?? (RESOLVED) - by El Forum - 01-24-2012, 10:14 PM
Tutorial error...?? (RESOLVED) - by El Forum - 01-25-2012, 02:02 AM
Tutorial error...?? (RESOLVED) - by El Forum - 01-25-2012, 02:03 AM
Tutorial error...?? (RESOLVED) - by El Forum - 01-30-2012, 08:04 PM
Tutorial error...?? (RESOLVED) - by El Forum - 01-31-2012, 01:20 PM
Tutorial error...?? (RESOLVED) - by El Forum - 02-09-2012, 04:57 AM
Tutorial error...?? (RESOLVED) - by El Forum - 02-09-2012, 10:50 AM
Tutorial error...?? (RESOLVED) - by El Forum - 02-12-2012, 02:44 PM
Tutorial error...?? (RESOLVED) - by El Forum - 02-12-2012, 07:08 PM
Tutorial error...?? (RESOLVED) - by El Forum - 02-12-2012, 08:41 PM
Tutorial error...?? (RESOLVED) - by El Forum - 02-16-2012, 01:07 PM
Tutorial error...?? (RESOLVED) - by El Forum - 02-16-2012, 03:25 PM
Tutorial error...?? (RESOLVED) - by El Forum - 03-04-2012, 09:42 PM
Tutorial error...?? (RESOLVED) - by El Forum - 07-18-2012, 09:13 AM
Tutorial error...?? (RESOLVED) - by El Forum - 08-22-2012, 03:18 AM
Tutorial error...?? (RESOLVED) - by El Forum - 08-22-2012, 03:24 AM
Tutorial error...?? (RESOLVED) - by El Forum - 10-16-2012, 01:28 PM
Tutorial error...?? (RESOLVED) - by El Forum - 02-03-2013, 02:25 AM
Tutorial error...?? (RESOLVED) - by El Forum - 02-04-2013, 11:35 AM
Tutorial error...?? (RESOLVED) - by El Forum - 08-26-2014, 08:20 AM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.