• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
getting a runtime error

#3
The problem is that this code runs fine on my Windows PC and also runs fine on my AWS Linux server. So I get the feeling this is a configuration "thing". From the Docs:

Extending Core Class

If all you need to do is add some functionality to an existing library - perhaps add a method or two - then it’s overkill to replace the entire library with your version. In this case it’s better to simply extend the class. Extending a class is nearly identical to replacing a class with a couple exceptions:
  • The class declaration must extend the parent class.

  • Your new class name and filename must be prefixed with MY_ (this item is configurable. See below.).
For example, to extend the native Input class you’ll create a file named application/core/MY_Input.php, and declare your class with:

Looking in config.php I have $config['subclass_prefix'] = 'MY_';

So why would the code be looking for loader.php instead of MY_loader.php? I didn't load composer on the Ubuntu PC. Do I need to?
proof that an old dog can learn new tricks
Reply


Messages In This Thread
getting a runtime error - by richb201 - 02-11-2019, 08:16 PM
RE: getting a runtime error - by neuron - 02-11-2019, 11:30 PM
RE: getting a runtime error - by richb201 - 02-12-2019, 05:15 AM
RE: getting a runtime error - by InsiteFX - 02-12-2019, 09:24 AM
RE: getting a runtime error - by richb201 - 02-12-2019, 10:29 AM
RE: getting a runtime error - by gmgj - 04-16-2019, 09:39 AM
RE: getting a runtime error - by InsiteFX - 04-16-2019, 03:00 PM

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.