find() should be renamed |
Hi there,
That might sound funny but the find() function creates a misunderstanding for me when I, the coder of my own project, read the code later. For example, when I read this after a while : PHP Code: $m = new GalleryModel(); I understand that I am trying to find "gallery_category_id". Actually, not. I believe the find() should be renamed as find_row_with(); - or - find_row_by_using(); If you want to specify more than one row to return by passing an array of primaryKey values instead of just one, that should be: find_rows_with(); I believe everything would be more readable : find_the_row_by_using($gallery_category_id) or just find_with([b]$gallery_category_id) [/b]is fine You see?
Normally, I call model functions name with By. For example: findBySlug(string $slug): Post
This won’t happen. But you could do it yourself - add ‘find_row_by_id’ to BaseModel.php and have it call find(), then you can use your own function. I personally like the terse nature of “find”
|
Welcome Guest, Not a member yet? Register Sign In |