Welcome Guest, Not a member yet? Register   Sign In
find() should be renamed
#1

Hi there,

That might sound funny but the find() function creates a misunderstanding for me when I, the coder of my own project, read the code later.

For example, when I read this after a while :

PHP Code:
$m = new GalleryModel();
$data['category_of_the_gallery'] = $m->find($gallery_category_id); 

I understand that I am trying to find "gallery_category_id".

Actually, not.

I believe the find() should be renamed as find_row_with();  - or - find_row_by_using();
If you want to specify more than one row to return by passing an array of primaryKey values instead of just one, that should be:
find_rows_with();

I believe everything would be more readable :

find_the_row_by_using($gallery_category_id)  or just  find_with([b]$gallery_category_id) [/b]is fine

You see? Smile
Reply


Messages In This Thread
find() should be renamed - by demyr - 08-05-2020, 12:58 PM
RE: find() should be renamed - by natanfelles - 08-05-2020, 01:13 PM
RE: find() should be renamed - by MGatner - 08-06-2020, 04:39 AM
RE: find() should be renamed - by demyr - 08-12-2020, 12:03 PM



Theme © iAndrew 2016 - Forum software by © MyBB