Welcome Guest, Not a member yet? Register   Sign In
M1 Chip MacOS php intl extension error
#1

(This post was last modified: 07-04-2021, 09:33 AM by ihaveerror.)

Hello i have m1 chip mac, i want install codeigniter 4 but i get intl extension error. I am using xampp 8.0.7, i edited my php.ini(extension=php_intl.dll) but intl extension doesnt work rather not exist. Can u help me?
Reply
#2

SEE below
Code:
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

extension=intl

;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

;; Make sure it is also listed here
;; I think I had to move it down here from above also

extension=intl

Check and make sure that it is in botrh places with out a semi-colon in front of them.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply
#3

I have installed intl extensions using https://www.macports.org ,check once it may help
Reply
#4

How do we go about this? we just install the macports that's all?
Reply
#5

(07-05-2021, 02:18 AM)InsiteFX Wrote: SEE below
Code:
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

extension=intl

;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

;; Make sure it is also listed here
;; I think I had to move it down here from above also

extension=intl

Check and make sure that it is in botrh places with out a semi-colon in front of them.
I still have the error.
There is only 1 extension=intl.dll in my php.ini
Code:
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

; If you wish to have an extension loaded automatically, use the following
; syntax:
;
;  extension=modulename
;
; For example:
;
;  extension=mysqli
;
; When the extension library to load is not located in the default extension
; directory, You may specify an absolute path to the library file:
;
;  extension=/path/to/extension/mysqli.so
;
; Note : The syntax used in previous PHP versions ('extension=<ext>.so' and
; 'extension='php_<ext>.dll') is supported for legacy reasons and may be
; deprecated in a future PHP major version. So, when it is possible, please
; move to the new ('extension=<ext>) syntax.
;
; Notes for Windows environments :
;
; - Many DLL files are located in the extensions/ (PHP 4) or ext/ (PHP 5+)
;  extension folders as well as the separate PECL DLL download (PHP 5+).
;  Be sure to appropriately set the extension_dir directive.

;extension=php_bz2.dll
;extension=php_curl.dll
;extension=php_dba.dll
;extension=php_exif.dll
;extension=php_fileinfo.dll
;extension=php_gd2.dll
;extension=php_gettext.dll
;extension=php_gmp.dll
extension=php_intl.dll
;extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_ldap.dll
Reply
#6

Aren’t DLL for Windows only? I’m pretty sure it’s a *.so file on macOS and Linux.
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
/*** NO support in private message - Use the forum! ***/
Reply
#7

(07-13-2021, 12:16 PM)includebeer Wrote: Aren’t DLL for Windows only? I’m pretty sure it’s a *.so file on macOS and Linux.

Yes. Also Apple is removing PHP from the Mac. We will eventually have to use MAMP or some other software to run PHP on a Mac.
Simpler is always better
Reply
#8
Wink 

xampp in mac do this:
if you php version is 8+
1, open mac terminal 
Code:
sudo port install php80-intl

2,find file
go to 
Code:
/opt/local/lib/php/extensions/ your some folder

an find like intl.so 
3,copy [font=monospace]intl.so to[/font]
[font="Lucida Grande", "Trebuchet MS", Verdana, Helvetica, Arial, sans-serif]/Applications/xampp/xamppfiles/lib/php/extensions/ your some folder / intl.so[/font]
Reply
#9

(07-13-2021, 05:04 PM)donpwinston Wrote:
(07-13-2021, 12:16 PM)includebeer Wrote: Aren’t DLL for Windows only? I’m pretty sure it’s a *.so file on macOS and Linux.

Yes. Also Apple is removing PHP from the Mac. We will eventually have to use MAMP or some other software to run PHP on a Mac.
Yes, I use MAMP on my Mac and it’s working “out of the box”. I didn’t have to install anything else.
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
/*** NO support in private message - Use the forum! ***/
Reply
#10

(07-14-2021, 06:06 AM)includebeer Wrote:
(07-13-2021, 05:04 PM)donpwinston Wrote:
(07-13-2021, 12:16 PM)includebeer Wrote: Aren’t DLL for Windows only? I’m pretty sure it’s a *.so file on macOS and Linux.

Yes. Also Apple is removing PHP from the Mac. We will eventually have to use MAMP or some other software to run PHP on a Mac.
Yes, I use MAMP on my Mac and it’s working “out of the box”. I didn’t have to install anything else.

I installed mamp but I still get an intl error.
Reply




Theme © iAndrew 2016 - Forum software by © MyBB