Welcome Guest, Not a member yet? Register   Sign In
Get URI segment returns nothing.... [RESOLVED]

well, the fact that the edit method is being called without the index.php in the uri means that the htaccess file is in place and at least two of the following segments are getting through to index.php (manufacturer and edit), but the rest of it is getting dropped.

in any case, why don't you take out the .htaccess and put in the index.php and see if it works without htaccess. if it works with the index.php then you know the problem is htaccess.

also, edit is an overused word, on an off-chance that it is conflicting, change it to something else.

I tried the same with with a "manufacturer" controller and the same, no go.
I also tried the whole thing prior to posting here with the index.php/no .htaccess in tact, same results.

Anyway back from work, so I'm going to try a fresh install.

Ok, a fresh install has fixed the problem. Yay for obscure errors.. not!

Theme © iAndrew 2016 - Forum software by © MyBB