• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No error when php_mysql.dll is missing

#1
[eluser]Unknown[/eluser]
Hi,

I don't know if this is a bug - maybe it's a feature - but it took me a few hours today, so I decided to post it.

I reinstalled my OS last month and today I needed edit one old CI web-project. So I quickly installed apache and php and mysql, then copied files and tried in browser if everything was working. And I saw just a blank page. When I tried uri to a controller, which doesn't exist, CI showed error, but when I typed correct adress, I saw just blank page.

So, where was the problem? I forgot install php_mysql.lib. I figured it out when I typed call of mysql_pconnect function and PHP showed error.

I think CI should say that some functions are missing. But, I don't know...

If you don't like this post, delete it Smile

Thanks,

Bye!

#2
[eluser]mglinski[/eluser]
This is a general error in CI in regards to all external libraries. If you are expecting something to be loaded and it is not CI will not tell you, just die a lonely death time and time again. While this is very annoying to most of us we have gotten used to it. Now that v1.7 is under active development i would hope that something will be done. This is especially a problem if you are developing an OS app for wide use across many servers by many people.
-Matt


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.