• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Flashdata freakauth

#1
[eluser]srpurdy[/eluser]
Hi All,

Im adding some flash data to my admin console. But having a strange problem. Basically it works except for some reason it loads a (1) in front of the message like "1The Information was updated successfully" This is of course only on the new messages I added to FreakAuth. Obivously I did something wrong but I would like to know what LOL Smile

Anyone have a clue? Smile

Code:
$msg = $this->db->affected_rows().$this->lang->line('FAL_sp_updated');
flashMsg($msg);
redirect('./admin/news');

And these are the added lines I added to the lang file.
Code:
$lang['FAL_sp_updated'] = 'The Information was updated successfully!';
$lang['FAL_sp_added'] = 'The Information was added successfully!';
$lang['FAL_sp_deleted'] = 'The Information was deleted successfully!';

Thanks Smile

#2
[eluser]Frychiko[/eluser]
it looks like the $this->db->affected_rows() in your msg variable set in the first row is outputting the 1, not sure what your desired output is...

#3
[eluser]srpurdy[/eluser]
[quote author="Frychiko" date="1221714017"]it looks like the $this->db->affected_rows() in your msg variable set in the first row is outputting the 1, not sure what your desired output is...[/quote]

ahhh ok Thanks. I never actually used flashdata before. I didn't understand it lol. I got it solved now just took out what you meantioned $this->db->affected_rows() As im just simply trying to display a simple message notfying the user that the request was actually carried out. Smile

Thanks!


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.