Running queries on oracle...

#1
[eluser]msangapu[/eluser]
I am having some trouble running queries on an oracle DB.

First of all, I am not sure if my connection properties are set properly. I know before it was saying "unable to connect" and now it no longer says that, but I get an error when I try to run a query.


Code:
A Database Error Occurred

Error Number:

SELECT * FROM "bb_course_list"


And here is my connection settings from database.php
Code:
putenv('ORACLE_HOME=/usr/local/oracle_php');
$db['oracle']['hostname'] = "PROD";        //PROD is actually the name of the SID
$db['oracle']['username'] = "*******";
$db['oracle']['password'] = "*******";
$db['oracle']['database'] = "IDS";
$db['oracle']['dbdriver'] = "oci8";
$db['oracle']['dbprefix'] = "";
$db['oracle']['pconnect'] = FALSE;
$db['oracle']['db_debug'] = TRUE;
$db['oracle']['cache_on'] = FALSE;
$db['oracle']['cachedir'] = "";
$db['oracle']['char_set'] = "utf8";
$db['oracle']['dbcollat'] = "utf8_general_ci";

I work for an institution and we normally have to do the putenv command before we connect to the database.


The error does not list any number!! I googled for quite some time and kept getting the article hosted on abbett.org. I am not sure what I'm doing wrong.

Anyone with CI + Oracle experience?

#2
[eluser]t'mo[/eluser]
I attempted to create a small test in CI at my workplace (a Java shop, Oracle 10g on the backend). I first tried to use the native Oracle drivers, or perhaps they were Microsoft's version of "native". Anyway, that didn't work. Next, I tried ODBC...which worked, all except for CLOB's.

And that ended my experiments with Oracle and CI. I might try again later, maybe not.

EDIT: I recall I had to have my table and column names in ALL CAPS. You might want to give that a try.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.