• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
routes not working

#11
[eluser]Thorpe Obazee[/eluser]
Try set your routing to lowercase

Code:
$route['info'] = 'homepage/info';
or

Code:
<?= anchor('info','Information');?>

#12
[eluser]learning_php[/eluser]
Hi,

I have tried both with the same error?

Thanks

#13
[eluser]Thorpe Obazee[/eluser]
ermm.. you post too fast Smile

Try the second one

Code:
<?= anchor('info','Information');?>

#14
[eluser]learning_php[/eluser]
Hi,

sorry

i have my link now set to
Code:
<li>&lt;?= anchor('info','Information');?&gt;</li>
and my route set to
Code:
$route['info'] = "homepage/Info";
and i get a 404? could it something else?

#15
[eluser]Thorpe Obazee[/eluser]
It probably is. Can you confirm that homepage/info does exist or doesn't throw a 404 when you browse homepage/info?

#16
[eluser]learning_php[/eluser]
Hi,

if i go towww.wesayido.co.uk/homepage/infoif i go to
i get a 404 but http://www.wesayido.co.uk/index.php/homepage/info/index i get the page.

#17
[eluser]Thorpe Obazee[/eluser]
http://www.wesayido.co.uk/index.php/homepage/info

http://www.wesayido.co.uk/index.php/homepage/info/index

both work

you forgot to put index.php on the first link.

I'm getting weird vibes on this thing Sad . Anyway, I'm off to a long weekend. Good luck.

#18
[eluser]learning_php[/eluser]
Hi,

I got it working on my localhost re-uploaded to the server and now when i click any link the url is correct but is displays the homepage?www.wesayido.co.uk


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.