• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.5.4 - jpg upload no longer working

#1
[eluser]Neovive[/eluser]
I have a test CI application on my Windows development machine that utilizes the code from the CI user guide to perform image uploads. The script runs fine in 1.5.3, but no longer uploads a valid image in 1.5.4. The uploaded image appears to be the proper filesize, but is not viewable in Windows and is not considered a valid image when using the CI Image Resize functions.

When I copy the original 1.5.3 Upload.php file into 1.5.4 it works fine.

#2
[eluser]Derek Allard[/eluser]
Darn.

Is this true of all jpgs, or just that 1, and if just that 1, could you attach it here so I can test it (if the forums will let you). If the forums won't let you, just email it to me (derek at derekallard dot com).

Thanks.

#3
[eluser]Neovive[/eluser]
The error occurs on all jpg's that I tried using the upload code from the user guide. It works fine if I drop in the old Upload.php from 1.5.3. I confirmed that the same thing happens on Linux (CentOS 4).

As an aside, I also noticed that all thumbnails created by the CI Image Manipulation library are assigned 777 permissions even if the original image is 644. Not sure if this is an OS issue or CI.

Thank you for looking into this.

#4
[eluser]Neovive[/eluser]
Does anyone know if this issue will be resolved in the next CI release?

#5
[eluser]alexsancho[/eluser]
I'm using 1.5.4 upload class to upload jpg's with no problem, i've run some similar issues using xmlrpc class to transfer binary data, but this is a different history i think

#6
[eluser]xwero[/eluser]
i don't have any problems on windows and linux, but i don't use resize.

#7
[eluser]barbazul[/eluser]
I remember I had a similar issue once with only one site.

It turned out that the problem was the images provided by my client where not in RGB format but in CMYK.

I solved the issue by running a simple batch in photoshop to switch every image to RGB.

After that, CI resizing worked fine


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.