• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The URI you submitted has disallowed characters.

#1
[eluser]singlepoint[/eluser]
My uri is

http://localhost/ci/index.php/blog

and there is nothing which should be disallowed. Any ideas?

#2
[eluser]pistolPete[/eluser]
Please post your config setting permitted_uri_chars:

Code:
//standard setting
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_-';

Try a different URI PROTOCOL.
Do you use a .htaccess file?

#3
[eluser]Unknown[/eluser]
i'm having the same problem
my uri is
Code:
http://localhost/CI/index.php/site
i tried the different uri protocols but no good
i also tried different permitted uri expressions a follows

$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-'; // Did not work
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_-'; // Did not work

if i manually add the controller name in the end then it works
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-site'; // DID WORK


everything else is default i haven't touched anything

#4
[eluser]singlepoint[/eluser]
Hey

No, I am not using a .htaccess file similarly the other settings are as follows.

$config['base_url'] = "http://localhost/ci/";
$config['index_page'] = "index.php";
$config['uri_protocol'] = "AUTO";
$config['url_suffix'] = "";
$config['language'] = "english";
$config['charset'] = "UTF-8";
$config['enable_hooks'] = FALSE;
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_-';

It is the simplest configuration, perhaps the first step for codeigniter. I am following the tutorial by Derek Jones placed on codeigniter website.

There is no character in the uri which should not be permitted.

#5
[eluser]Phreax[/eluser]
[quote author="hris" date="1251108525"]i'm having the same problem
my uri is
Code:
http://localhost/CI/index.php/site
i tried the different uri protocols but no good
i also tried different permitted uri expressions a follows

$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-'; // Did not work
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_-'; // Did not work

if i manually add the controller name in the end then it works
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-site'; // DID WORK


everything else is default i haven't touched anything[/quote]

I have the same problem - the same solution works

Code:
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\-blog'; // DID WORK

I dont want to have to re-write this line for every controller - is there an easier option?

EDIT:

Code:
$config['permitted_uri_chars'] = '';

seems to work for localhost - I wonder if the default will work ok online? I will continue to use this to develop locally for the time being.

#6
[eluser]verynewtothis[/eluser]
May be updating URI.php file from here will help..

but before trying this, please do read this page carefully.

#7
[eluser]Phreax[/eluser]
Thank you - I tried this and it worked.

Many Thanks,
Phreax

#8
[eluser]singlepoint[/eluser]
Great. This helps. I am thankful.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.