Code Igniter and PHP 5.3

#1
[eluser]Unknown[/eluser]
Hi I just upgraded to Snow Leopard, which comes with PHP 5.3 out of the box. As such, all of my code igniter development sites on my local machine no longer function due to CI's incompatibility with PHP 5.3.

I've read that the latest CI version in SVN supports PHP 5.3.

I've wondering 3 things:

1. How long until we see an officially supported release supporting PHP 5.3?
2. Do you have a recommended upgrade path to the latest SVN version?
3. Will the latest SVN version work with previous versions of PHP (5.2.4, etc)?

Thanks!

Mike

#2
[eluser]MurkeyDismal[/eluser]
I grabbed the latest from the SVN repository and have not seen any evidence of it not working with my earlier code or on a server running PHP 5.2.8. Although it is not recommended to use on your final release as it is still a work in progress, a work that is, (in my opinion is worthy of putting on a development platform).

As for an oficial release of 1.7.2, the consensus on the forum seems to be when it arrives.

#3
[eluser]John_Betong[/eluser]
[quote author="mbiang" date="1251767239"]Hi I just upgraded to Snow Leopard, which comes with PHP 5.3 out of the box. As such, all of my code igniter development sites on my local machine no longer function due to CI's incompatibility with PHP 5.3.

I've read that the latest CI version in SVN supports PHP 5.3.

I've wondering 3 things:

1. How long until we see an officially supported release supporting PHP 5.3?
2. Do you have a recommended upgrade path to the latest SVN version?
3. Will the latest SVN version work with previous versions of PHP (5.2.4, etc)?

Thanks!

Mike[/quote]
 
For the errors which cause your applications to "no longer function" then search this forum with "this is my error". I am sure that it has been discussed at length and solutions/kludges supplied.
 
>>> 1. How long until we see an officially supported release supporting PHP 5.3?
This has been discussed and answered from the Developement Team.
 
>>> 2. Do you have a recommended upgrade path to the latest SVN version?
Search the forum and for the solution.
I use the latest SVN version and use this version switching my index.php file:
Code:
define('LOCALHOST', 'localhost' === $_SERVER['SERVER_NAME']);
    if (LOCALHOST)
    {
         $system_folder = "./ci_svn/system";
    }else{    
         $system_folder = "./ci_system"; // 1.71
    }
 
>>> 3. Will the latest SVN version work with previous versions of PHP (5.2.4, etc)?
It does on my machine Smile. Shout in the forum if it does not work...
 
 
 

#4
[eluser]wabu[/eluser]
Mike, thanks for posting. I wasn't aware of this, though I suppose it's to be expected as PHP jumps ahead. Snow Leopard should be on its way to me, someday (under Amazon's "Ship when we feel like it" option Wink so I'll be facing the same issue. I thought PHP would be the one thing I don't have to reinstall!

I notice "Server Requirements" in the User Guide doesn't mention this, only "PHP version 4.3.2 or newer." Maybe it should be amended to include a "less than" version.

#5
[eluser]szazman[/eluser]
I can't use
<?=
anymore.
that suxx because i've always used <?
right now i have to rewrite all my projects,files to <?php

#6
[eluser]Dam1an[/eluser]
szazman, although you should rewrite all your PHP tags to full tags (at the very least in everything other then views as CI can rewrite these for you) PHP5.3 just disables short tags by default, but you can change that in php.ini

#7
[eluser]szazman[/eluser]
Indeed. THX


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.