• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Database config and error display problem

#1
[eluser]Unknown[/eluser]
I'm trying to get going with Codeigniter now and running in to a big problem. I seem to have error logging and the display of errors turned on (it's the default setting), but I can't figure out what is wrong with the Database library. As soon as I try to call it (either from autoload or explicitly) I get just a blank page instead of all the content that should be there....like the error message. I'm pretty damn sure I'm feeding the database library the right server info, but it refuses to start and won't tell me why.

The question is: how do I get access to the error message? I can't fix it if I don't know what's wrong.

edit: I have it working on my paid-for web server, but not my local machine. MySQL itself, PHP, and Apache are all otherwise working very well on my local machines. On the hosted site it will throw an error and on my local machines it will only die and give me a blank page. What's up here?

edit2: I meant to say it's working just fine with the correct settings on the remote web server. It will also throw an error with the incorrect settings. Locally, all I get is a blank page with correct or incorrect settings.


FIXED! After nearly a day of searching to fix this problem I finally found a post that narrowed it down for me: re-install PHP and include the MySQL module - which I thought was enabled by default.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.