• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A CodeIgniter compatible email-library powered by PHPMailer

#1
GitHub: ivantcholakov/codeigniter-phpmailer

This library is compatible with CI2 and CI3 and uses the same API (with minor extension) as the original Email library. Use it if:

1. You have problems with non-Latin origin languages.
2. You have problems with SMTP with encryption (Gmail accounts).
3. You want to embed an image (logo for example) inside the body of your messages.
Reply

#2
Hey, great stuff! God work. (direct link: https://github.com/ivantcholakov/codeigniter-phpmailer)

Reply

#3
(10-23-2014, 02:54 PM)ivantcholakov Wrote: GitHub: ivantcholakov/codeigniter-phpmailer

This library is compatible with CI2 and CI3 and uses the same API (with minor extension) as the original Email library. Use it if:

1. You have problems with non-Latin origin languages.
2. You have problems with SMTP with encryption (Gmail accounts).
3. You want to embed an image (logo for example) inside the body of your messages.
----------------
Ivan: could you tell us how to install in CI 2? the instructions in github only indicate how to install it in CI 3. Thanx.
Reply

#4
(10-23-2014, 02:54 PM)ivantcholakov Wrote: GitHub: ivantcholakov/codeigniter-phpmailer

This library is compatible with CI2 and CI3 and uses the same API (with minor extension) as the original Email library. Use it if:

1. You have problems with non-Latin origin languages.
2. You have problems with SMTP with encryption (Gmail accounts).
3. You want to embed an image (logo for example) inside the body of your messages.

-------------------------------------------------------------------------

About installation in CI 2, just edit config/email.php according to your system-account settings, all the files should be moved relative to their corresponding folders within the application folder, no rename needed, that´s it! thanx Ivan, great work!
Reply

#5
@satchie

Install the library in the same way as the README.md says, pick up the latest release. I don't test it with CI2 anymore, but code has been written to detect CodeIgniter's version, it should work. I have no reported issues about using the library with CI2.
Reply

#6
A have prepared a Composer package that is compatible with CodeIgniter 3.1.x. See https://packagist.org/packages/ivantchol...-phpmailer

For supporting CodeIgniter 2.x and CodeIgniter 3.0.x a manual installation of an older version of this library is needed, see the following repository's branch https://github.com/ivantcholakov/codeign...1.3-stable
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.