adLDAP

#1
[eluser]joe4[/eluser]
Hi

I am using version 2.1 of adLDAP.php. It seems to work on my
local WAMP server install with codeigniter 1.7.1 and php version
5.2.9-2

I moved to a development server with php 5.3.2 and codeigniter version 1.7.2
I get the following message:

Message: adLDAP::adLDAP(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Paris' for '2.0/DST' instead

Filename: libraries/adLDAP.php

Line Number: 107


According to this url and modification :
http://philsturgeon.co.uk/news/2009/12/C...on-PHP-5.3

It should work but it doesnt. Do you have any idea?

Thanks!

#2
[eluser]pickupman[/eluser]
I had this before. It appears to happen when the parameter is not set in the php.ini file. Check your php.ini for
Code:
; Defines the default timezone used by the date functions
date.timezone =
Here are the options for the timezone settings:
timeszones.america

Try setting this parameter, and restart php service.

#3
[eluser]joe4[/eluser]
Hi,

Thanks. I tried it with

date.timezone = "Europe/Amsterdam"

But unfortunately it did not work.

Any further ideas?


Thanks, Joe4

#4
[eluser]pickupman[/eluser]
What about instead of Phil's recommendation you would use in your index.php:
Code:
if( ! ini_get('date.timezone') )
{
  date_default_timezone_set("Europe/Amsterdam");
}

#5
[eluser]joe4[/eluser]
Thanks,

But as I said, I tried that too. And it did not work.


Thanks, Joe4


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.