• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
htaccess problem with sub pages

#11
[eluser]vmcgreevy[/eluser]
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>

Like I said I've switched to the default htaccess, and I'm getting the following:

An Error Was Encountered
The URI you submitted has disallowed characters.

#12
[eluser]Clooner[/eluser]
[quote author="vmcgreevy" date="1276613825"]<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>

Like I said I've switched to the default htaccess, and I'm getting the following:

An Error Was Encountered
The URI you submitted has disallowed characters.[/quote]

Try this
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]
</IfModule>

#13
[eluser]vmcgreevy[/eluser]
Quote:Try this
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L,QSA]
</IfModule>

Nope, no different.

#14
[eluser]Clooner[/eluser]
How is your $config[‘uri_protocol’] set now?

#15
[eluser]vmcgreevy[/eluser]
$config['base_url'] = "http://localhost/site/";

#16
[eluser]Clooner[/eluser]
[quote author="n0xie" date="1276612710"]Try couger's htaccess.[/quote] LOL Big Grin

#17
[eluser]vmcgreevy[/eluser]
$config['permitted_uri_chars'] = '';

Setting this to blank makes it work, any ideas why 'a-z 0-9~%.:?=_\-' would not work?

#18
[eluser]Clooner[/eluser]
[quote author="vmcgreevy" date="1276615728"]$config['permitted_uri_chars'] = '';

Setting this to blank makes it work, any ideas why 'a-z 0-9~%.:?=_\-' would not work?[/quote]

can you post the rewritten url here?

#19
[eluser]vmcgreevy[/eluser]
[quote author="clooner" date="1276616853"][quote author="vmcgreevy" date="1276615728"]$config['permitted_uri_chars'] = '';

Setting this to blank makes it work, any ideas why 'a-z 0-9~%.:?=_\-' would not work?[/quote]

can you post the rewritten url here?[/quote]

http://localhost/site/news

#20
[eluser]Clooner[/eluser]
[quote author="vmcgreevy" date="1276616898"]http://localhost/site/news[/quote]
I mean the url when it exits the rewriter!
e.g. http://localhost/temp/index.php/segment/segment2

and again what is your uri_protocol set to?


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.