• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI + YATS Problems

#1
[eluser]vbnullchar[/eluser]
hi, im creating a multi application ci+yats project..

here are the problems i encountered:

http://localhost/ci/ (loads the default applications. ok!)
http://localhost/ci/purchasing (loads the sub-applications. ok!)
http://localhost/ci/purchasing/ (Error! trailing slashes issues).
http://localhost/ci/purchasing/items/ (loads the page without styles)
http://localhost/ci/purchasing/items/browse (loads the page without styles)

currently this is my directory structure

Code:
.
|-- assets
|   |-- default
|   |   |-- css
|   |   |-- images
|   |   `-- script
|   |-- purchasing
|   |   `-- default
|   |       |-- css
|   |       |   `-- layout.css
|   |       |-- images
|   |       `-- script
|   |           `-- init.js
|   `-- shared
|       |-- css
|       |-- images
|       `-- script
|-- index.php
|-- purchasing.php
|-- system
|   |-- application
|   |   |-- config
|   |   |-- controllers
|   |   |-- errors
|   |   |-- helpers
|   |   |-- hooks
|   |   |-- index.html
|   |   |-- libraries
|   |   |-- models
|   |   |-- views
|   |   `-- ~purchasing
|   |       |-- config
|   |       |   |-- autoload.php
|   |       |   |-- autoload.php.dist
|   |       |   |-- config.php
|   |       |   |-- database.php
|   |       |   |-- hooks.php
|   |       |   |-- index.html
|   |       |   |-- layout.php
|   |       |   |-- mimes.php
|   |       |   |-- routes.php
|   |       |   |-- smileys.php
|   |       |   `-- user_agents.php
|   |       |-- controllers
|   |       |   |-- index.html
|   |       |   |-- index.php
|   |       |   `-- items.php
|   |       |-- errors
|   |       |   |-- error_404.php
|   |       |   |-- error_db.php
|   |       |   |-- error_general.php
|   |       |   |-- error_php.php
|   |       |   `-- index.html
|   |       |-- helpers
|   |       |-- hooks
|   |       |   `-- index.html
|   |       |-- index.html
|   |       |-- libraries
|   |       |   |-- index.html
|   |       |   `-- layout.php
|   |       |-- models
|   |       |   |-- index.html
|   |       |   `-- layout_model.php
|   |       `-- views
|   |           |-- default
|   |           |   |-- common
|   |           |   |   |-- copyright.php
|   |           |   |   |-- footer.php
|   |           |   |   |-- header.php
|   |           |   |   `-- sidebar.php
|   |           |   `-- content
|   |           |       |-- index.php
|   |           |       |-- items
|   |           |       |   `-- browse.php
|   |           |       `-- loader.php
|   |           |-- index.html
|   |           `-- loader.php
|   |-- cache
|   |   `-- index.html
|   |-- codeigniter
|   |-- database
|   |-- fonts
|   |-- helpers
|   |-- language
|   |-- libraries
|   |-- logs
|   |-- plugins
|   `-- scaffolding
|       |-- Scaffolding.php
|       |-- images
|       |   |-- background.jpg
|       |   |-- index.html
|       |   `-- logo.jpg
|       |-- index.html
|       `-- views
|           |-- add.php
|           |-- delete.php
|           |-- edit.php
|           |-- footer.php
|           |-- header.php
|           |-- index.html
|           |-- no_data.php
|           |-- stylesheet.css
|           `-- view.php

#2
[eluser]Majd Taby[/eluser]
off topic, how did you print your folder structure like that?

#3
[eluser]vbnullchar[/eluser]
Smile in linux there is a small application called tree i just redirected the output to a text file

#4
[eluser]vbnullchar[/eluser]
ok.. i got it.. i change the $config['base_url'] = "http://localhost/ci"; in my sub-application folder..


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.