• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
set_value() of form validation doesn't work for 2nd time

#1
[eluser]Unknown[/eluser]
Hi,

* I have a form using set_value() to repopulate previous value. (using CI 2.0.2)

* e.g. If a user forgot to fill in a field, he clicks submit button. There is error message for that empty field. There other fields' value will be repopulated.
* If the user fix his error, but he changes his mind and he modifies some of the existing fields, the values of them are actually old values (i.e. set_value only populates the very first value, it never keep the newer value)

* Is it just me or other get the same problem?

#2
[eluser]LuckyFella73[/eluser]
Hi kenpeter - first of all welcome to the CI forums!

Please post the involved form- and controller code, it's
the only way we can help you with that. I guess you have
just a minor error in your code.

#3
[eluser]Mirge[/eluser]
[quote author="LuckyFella73" date="1312291042"]Hi kenpeter - first of all welcome to the CI forums!

Please post the involved form- and controller code, it's
the only way we can help you with that. I guess you have
just a minor error in your code.[/quote]

heh... off-topic, but d-mn you... just smacked my screen b/c of your avatar.

#4
[eluser]Unknown[/eluser]
* just a minor error in your code.
* Indeed, 2 input field have the same name.
* Thanks guys

* "heh… off-topic, but d-mn you… just smacked my screen b/c of your avatar." lol


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.