• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issue with CI with JSON when using URI routing

#1
[eluser]ximbo_fett[/eluser]
Thank you in advanced for any help that anyone can give me.

I am having a strange issue using CI with Json. Unfortunately the application this is on resides inside a VPN on a system with no Internet access so I cannot provide a link to that specific appplication.

I designed a JSON function that POSTs the selected value of one drop-down input, which is the campus location, sends it to a controller that pulls out all the building numbers for that campus. The controller then puts this information into an array and echoes the JSON encoded array which then the contents of the array then gets created into options for another drop-down input.

I have no problem with this function when the main controller that this is housed in is running without any URI routing. The problem occurs when I run the same controller passing a URI string key for the record in order to edit the record.

When I push a URI string of 1 key, which is the record id of the what was created previously, this JSON function doesn't work. There are no javascript error when I check the web developer toolbar. The function simply doesn't get called. This is the same when I run the default controller in what I call the create new record mode and I place the forward slash '/' after the controller name. The JSON function stops working entirely.

Nothing changes in where the controller gets called - everything is the same directory relationship-wise so I am at my wit's end on what to do.

Thanks once again for any help.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.