• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to Set up a Remote Testing Environment ?

#1
[eluser]vincej[/eluser]
Hi - my site is almost done. Now I want to put all my existing code up on a server for remote testing. However, I want it in a separate folder, not available to the public as there is an existing old site still installed. So .. I created a separate folder 'CLFarms' inside /public/ and uploaded all my files off my C drive.

I made no further changes.

I am now getting 3 errors:

Code:
Message: Cannot modify header information - headers already sent by (output started at /services9/webpages/g/r/organiclife.com/public/CLFarms/index.php:2)

Code:
Message: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /services9/webpages/g/r/organiclife.com/public/CLFarms/index.php:2)

Code:
Message: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /services9/webpages/g/r/organiclife.com/public/CLFarms/index.php:2)


Needless to say my site does not display anything.

I tried changing the config file to see if that would help - I made the following changes to no effect:

Code:
$config['base_url'] = 'http://organiclife.com/public/CLFarms/';


I have tried using the config with the /public/ in and out of the address - it made not difference.

Can anybody tell me where I am going wrong ??

Many Many thanks !

#2
[eluser]vincej[/eluser]
Ok - Many Thanks ... I realised my mistake adn so I fixed all the output errors by removing all the white space so I'm not getting any messages anymore.

However, I'm still getting a white screen of nothing ...

any ideas where I should look ?


Many Thanks

#3
[eluser]tomcode[/eluser]
Do You have error reporting enabled ?

Code:
// in Your index.php
error_reporting(-1);

#4
[eluser]vincej[/eluser]
Thanks Tomcode - I had my error reporting set to E_ALL . I changed it to -1 to no effect, so I put it back.

I have tried putting up a 'Hello Sailor' test page onto the folder and it worked fine in the browser.

However when I try to go to :

http://www.organiclife.com/CLFarms/index.php

I just get a plain empty white screen

any advice ??

Many many thanks !

#5
[eluser]tomcode[/eluser]
Your link does not work for me, is redirected to http://nameteam.com

error_reporting: -1 gives You all errors, see error_reporting(), the examples

You can use CodeIgniter's log, maybe it shows You something, see config/config.php

Check Your application files for other white space issues, do You use somewhere

do an echo in Your default controller, maybe You get an output


#6
[eluser]vincej[/eluser]
Hi TomCode, No disrespect, but I obscured the name of my site - so it will resolve to nameteam.

I don't have header problems any more .. when I say that I have a screen of white I mean, I get nothing in it, like the file is empty. Of course it is not. My test file "Hello Sailor" does run php so I know that PHP is working.

There has to be something in the codeigniter config or index which is not allowing the site to work.

Any advice is very welcome -

Vielen Dank aus Kanada !


#7
[eluser]tomcode[/eluser]
Did You check what I proposed You ?

You may also install a vanilla CodeIgniter and see whether that runs on the server. I'm pretty sure it's either :

- a whitespace issue
- some PHP error
- maybe a file couldn't be loaded

Usually You get either a PHP error or a CodeIgniter error message, but sometimes (rarely, though) CodeIgniter gives a white screen.

Is Your server a Windows server ? I know only installations under Apache.

#8
[eluser]vincej[/eluser]
Many Thanks for all your advice. I checked the error logs and it was clear that I had not properly set up the DB connection, Once corrected - no more white screen. However, now I have a different Header problem .. that is in a separate post !

Thanks


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.