Validation not really backwards compatible

#1
[eluser]t'mo[/eluser]
The talk about PHP4 backwards compatibility is nice, but there's one gaping hole where CI doesn't work the same in PHP5 as it does in PHP4 - Validation, specifically when trying to use it via autoload.

The problem is that values of "$this->validation->error_string" and invalid fields get lost once you get to the View. Is it because of a bug in CI? a limitation in PHP4?

And yes, I realize you can:
Code:
class MyController extends Controller {
    function doStuff() {
      $this->load->library('validation');
  // ...
in any Controller's method, but it will only lead to duplication of code in many places of my app.

I should probably break down and get debugging working to figure this out myself, but if anybody, *Anybody* knows the answer (or at least has a suggestion for where to look), it would be much appreciated.

#2
[eluser]xwero[/eluser]
thread with fix but grab the controller library from SVN the fix is added.


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.