Possible codeigniter bug in the HTTP body response

Do any of you know why codeigniter prefixes three characters \r (or \0 I didn't figure out) to the body of any HTTP response?

When it comes to using ajax it's causing me going mad beacuase ajax string cannot be parsed properly... To solve temporarily the situation I did the following :

Echoing ajax this way :

and then retrieve this data in the following way:

var data1 = data.split("-");

alert(data1[0]);// this prints \r\r\r
alert(data1[1]);// this prints {"hello":"world"}

var data1 = JSON.parse(data1[1]);

But I leave you judge the cleaness of this solution... anyone has any clue why this error occurs with CI ?

what I'm asking is, what may cause "/r/r/r" or maybe (/n/n/n) to be output before the actual output of the controller may it be a view or an echo statement,
maybe somethin is messed up in my config files, or something like that?

Start a native session, it may tell you the file and line where the output begins

I've already tried this and no error occurs.


echo "hello world!";

OK, solved.
The problem was caused by the Unix to dos converter I was forced to use to read some of the
files in the project and this messed things up.

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.