• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 2.2.0 HMAC mismatch error

#1
[eluser]ci_user[/eluser]
After upgrading from CodeIgniter 2.1.3 to 2.2.0 I am getting the error:

Quote: Session: HMAC mismatch. The session cookie data did not match what was expected.

The Mcrypt extension is enabled. If I set $config['sess_encrypt_cookie'] = FALSE; (not an option for production) there is no error. Any help greatly appreciated.

#2
[eluser]ci_user[/eluser]
http://stackoverflow.com/questions/24121...atch-error

#3
[eluser]timpa[/eluser]
Is there something else that would cause the error?
I've grabbed the new version, and I'm still seeing it over and over again in my logs when I try to log in...

#4
[eluser]Unknown[/eluser]
I'm having the same issue too (with the new 2.2.0 version)

#5
[eluser]timpa[/eluser]
I've locked down the issue to a bug in A3M that was doing it's own thing with the sessions class on top. They fixed it up and I'm off and running now.

Could be a plugin you're using too?

#6
[eluser]ci_user2014[/eluser]
I am also using the new 2.2 version and I am still getting random HMAC mismatch errors. It works fine most of the times. This random error causes the user to being logged out. Any help will be appreciated.

#7
[eluser]CroNiX[/eluser]
Narf said that it was fixed in the 2.2 branch on github, not the DL link on this EllisLabs website. Did you get it from github? If so, you'd need to check any library that you're using or anything else that uses the CI encrypt library.

#8
[eluser]ci_user2014[/eluser]
Yes, I did download it from github. I can try and see if the problem goes away if we do not use CI encrypt library.

We do use simultaneous ajax which triggers every 5 secs and we have extended the sessions library to ignore sess_update() when the request is an ajax request. I found a post on sessions race condition (Race Condition). Could this be the problem or is it fixed in CI 2.2 ? Since our site heavily depends on simultaneous ajax, should we consider directly moving to CI 3.0?

Thanks!

#9
[eluser]MrTomTom[/eluser]
I'm getting similar issues as well -- have latest 2.2 and still getting HMAC errors.

#10
[eluser]ci_user2014[/eluser]
Please look at this post. This fixed our issues.
HMAC mismatch error #3094


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.