• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 3.1 and the minimal required PHP version

#1
This thread http://forum.codeigniter.com/thread-6402...27352.html provokes me to raise a question to the developers.

What would you say about bumping for CodeIgniter 3.1 the minimal PHP version to 5.4?

I am neutral to this subject. My motivation is purely social - let them stop crying about PHP 5.2.
Reply

#2
I think its pointless.

1st of all the recommended version is 5.5. At the minimum, the framework is stable but its a developer risk to work with so old PHP version.
2nd the minimum fits the version which is used for writing the framework and its not 5.4.
3rd this way 3.1 will have BC points to 3.0 but it wont fit the 4.0 which will come eventually at some point next year.
4th why to create unnecessary work to people who don't care about safety and stability. Those who care about these things are already working with at least 5.4 - 5.6
Best VPS Hosting : Digital Ocean
Reply

#3
We've already "discussed" this internally and 5.2 will be dropped.

Whether we go to 5.3 or 5.4 depends on what we really need as features, but I personally don't see anything that would require traits and there's no other major feature on the list.
Reply

#4
(01-06-2016, 01:09 PM)Narf Wrote: We've already "discussed" this internally and 5.2 will be dropped.

Whether we go to 5.3 or 5.4 depends on what we really need as features, but I personally don't see anything that would require traits and there's no other major feature on the list.

#3 and #5 on that list seem like good reasons to drop anything below 5.4.
Reply

#5
(01-25-2016, 09:11 AM)katz Wrote:
(01-06-2016, 01:09 PM)Narf Wrote: We've already "discussed" this internally and 5.2 will be dropped.

Whether we go to 5.3 or 5.4 depends on what we really need as features, but I personally don't see anything that would require traits and there's no other major feature on the list.

#3 and #5 on that list seem like good reasons to drop anything below 5.4.

#3 and #5:

Quote:- Function array dereferencing has been added, e.g. foo()[0].
...
- <?= is now always available, regardless of the short_open_tag php.ini option.

Are you sure this is what you're talking about?

#3 we can deffinately do without; it's just syntactic sugar for $foo = foo(); $foo[0];
#5 is completely irrelevant to CodeIgniter, bar a few default error views.

Don't get me wrong, we do expect users to run at least 5.5 anyway and these are obviously nice features, but they are not namespaces-level nice - you don't base version requirements on that.
Reply

#6
If CodeIgniter's code is globally searched against is_php('5.4') it becomes more clear.

#5 actually is useful about loading views, with include statement only, code that loads view source and evals it could be eliminated.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.