• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Production Site and 404's

#1
I have developed a custom CRM locally on my machine, and have a staging version in a subdirectory of my portfolio site for the client's office manager and me to test - no issues.

We're ready to launch, so I FTP'd the application to a subdirectory of the client's site, changed everything to point to their database. I get the login page, but when I log in, I get taken to a 404 (Error 404: NOT FOUND! This domain name has just been registered.) message that the Hosting Provider uses for parked domains.

Where should I be looking to troubleshoot this issue? Is it a problem with the hosting provider or did I miss something when I deployed the application? My portfolio site is on Godaddy (no problems) and the client's site is on 1and1 (problems).
Reply

#2
Although nobody bothered to respond to this post, I thought I would post the solution I finally found -

Even though the application worked fine in my test server in a subdirectory, in the production server putting the application in a subdirectory was causing all the problems. I made several changes to my .htaccess file, but the one I think did the trick was to add
PHP Code:
RewriteBase /CRM
where CRM is the name of my subdirectory.
Reply

#3
Quote:Although nobody bothered to respond to this post,...

I am glad you found a solution and I am sorry that it was such an obvious thing. I reckon that most people thought that since you had built a CRM system (a fairly complex build) that it was not anything obvious and there simply was not enough info to help. In fact, I am guessing that most people thought it must be a problem in your login coding, which would have meant doing a full diagnosis and debug, a job not really fit for a forum answer.

If you had posted that your url was trying to reach www.mydomain.com/page instead of www.mydomain.com/crm/page then perhaps people would have recognized the problem instantly, rather than the no replies you got.

The CI forum is very active, I am sorry you did not get any help, it is not that no one was bothered, just an impossible question to answer without providing tons of dead ends.

Good luck with your CRM,

Paul.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.