• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A easy question for Ci4.0 ( can i Upgrade from Ci3 to Ci4 ?)

#1
Star 
I think this is one easy question, because i hope to sure for my project so i must create this topic question  Blush

Question: 
I am in a Project which is building on Ci3.0.6, rummor about Ci4.0 will was born in next times, my question is may i update my Project from Ci3.0.6 to Ci4.0 ? ( My project about Mini Supermarket, i has only created files in Library, Helper, Controller and Models )

Please can tell me can i sure to Upgrade my Project from Ci3.0.4 to Ci4.0 ? That is very important to me because my Project will Complete at middle of next year but in that times the Ci4.0 can be republic  Smile

Please help my small brian !  Blush verry verry thanks

i am vietnamese so not pretty about english 
Reply

#2
CodeIgniter 4 will not be backwards compatible with CodeIgniter 3.
There will be philosophical similarities, but the codebase will exploit PHP7.
There will be a section in the user guide about upgrading from CI3 to CI4, but it will definitely not be as easy as replacing the "system" folder.
Reply

#3
(05-27-2016, 02:19 AM)ciadmin Wrote: CodeIgniter 4 will not be backwards compatible with CodeIgniter 3.
There will be philosophical similarities, but the codebase will exploit PHP7.
There will be a section in the user guide about upgrading from CI3 to CI4, but it will definitely not be as easy as replacing the "system" folder.
Can i move files in Library, Helper, Controller and Models to Ci4 for reuseHuh
Reply

#4
3rd party or custom class's will be reusable if they work under PHP 7, but if you use some CI 3 features inside your custom libs, they may not work.
Best VPS Hosting : Digital Ocean
Reply

#5
Also you better make sure that your hosting provider will run PHP 7 right now most do not they are only offering PHP 5.6.x
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#6
(05-27-2016, 04:36 AM)InsiteFX Wrote: Also you better make sure that your hosting provider will run PHP 7 right now most do not they are only offering PHP 5.6.x

Helpful: http://phpversions.info/php-7/
Reply

#7
(05-27-2016, 03:42 AM)sv3tli0 Wrote: 3rd party or custom class's will be reusable if they work under PHP 7, but if you use some CI 3 features inside your custom libs, they may not work.

Big Grin  Oh, so thanks you !
My Ci3.0.6 Project only use helpers and database library of CI3.0.6, another features were builted by my Team ( created in Library folder of Ci3.0.9 ! be sure ), and with your sweet answer my Project can Move to Ci4.0, now i can free about my question caption  Heart Heart
Reply

#8
(05-27-2016, 04:44 AM)Narf Wrote: Helpful: http://phpversions.info/php-7/

WOW - that is a great link because it shows the actual *version* of PHP 7 the hosting company is running.
A very good guide for which hosting companies do their updates. Thank you for posting.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.