• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation/Startup Issue with PHP 7 built-in server

#1
Hello All,

Thanks in advance for any input!

I git-cloned the repo to my development Mac (running Sierra/php 7) and started it using PHP7's built-in webserver like this:

Code:
➜  CodeIgniter4 git:(develop) php -S  localhost:7778 --docroot=/Users/moo/Library/Mobile\ Documents/com~apple~CloudDocs/Sites/CodeIgniter4/public
PHP 7.0.5 Development Server started at Tue Jul 26 17:38:09 2016
Listening on http://localhost:7778
Document root is /Users/moo/Library/Mobile Documents/com~apple~CloudDocs/Sites/CodeIgniter4/public
Press Ctrl-C to quit.

After accessing http://localhost:7778 in the browser, I get these errors:
Code:
[Tue Jul 26 17:38:15 2016] PHP Fatal error:  Uncaught Error: Class 'Config\App' not found in /Users/moo/Library/Mobile Documents/com~apple~CloudDocs/Sites/CodeIgniter4/public/index.php:237
Stack trace:
#0 {main}
 thrown in /Users/moo/Library/Mobile Documents/com~apple~CloudDocs/Sites/CodeIgniter4/public/index.php on line 237
[Tue Jul 26 17:38:15 2016] 127.0.0.1:51266 [500]: / - Uncaught Error: Class 'Config\App' not found in /Users/moo/Library/Mobile Documents/com~apple~CloudDocs/Sites/CodeIgniter4/public/index.php:237
Stack trace:
#0 {main}
 thrown in /Users/moo/Library/Mobile Documents/com~apple~CloudDocs/Sites/CodeIgniter4/public/index.php on line 237

Am I making a setup mistake?

Thanks,

Jason

(Using CodeIgniter since 1.x)
Reply

#2
I have the same problem.

Fatal error: Uncaught Error: Class 'Config\App' not found in /Users/HANHAN/Dropbox/玫瑰和绿叶/hd/CodeIgniter4-develop/public/index.php:237 Stack trace: #0 {main} thrown in /Users/HANHAN/Dropbox/玫瑰和绿叶/hd/CodeIgniter4-develop/public/index.php on line 237
Reply

#3
Did you set your base_url in ./application/App.php ?
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#4
I wonder if it has to do with different characters in the path? Or, in the case of the first example, it's running out Mobile Documents in Library, which may have different restrictions on it. Can you try to run it in your home directory maybe? Ensure there's no spaces, foreign language symbols, etc. If that works, then we have something to start diagnosing.
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#5
(08-02-2016, 07:00 PM)kilishan Wrote: I wonder if it has to do with different characters in the path? Or, in the case of the first example, it's running out Mobile Documents in Library, which may have different restrictions on it. Can you try to run it in your home directory maybe? Ensure there's no spaces, foreign language symbols, etc. If that works, then we have something to start diagnosing.

 Thanks a lot! The problem is solved. I have placed the project in the htdocs folder in Mamp on my mac  and I solved the problem. Before I had put the project in a folder with Chinese name in Dropbox . I think the problem was the Chinese characters in the path.
Reply

#6
Glad that got it working for you!
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.