Welcome Guest, Not a member yet? Register   Sign In
Not sure why I get these errors every now and then

I have an authentication app using IonAuth. This is the first time I've used IonAuth and every now and then I get this error...

A PHP Error was encountered

Severity: Warning
Message: unlink(/tmp/ci_sessionbd911eef382db5c4a4831662dfe3dd58490b44c3): Operation not permitted
Filename: drivers/Session_files_driver.php
Line Number: 354
File: /home2/xx/public_html/xx/index.php
Line: 292
Function: require_once

it only happens maybe 1 out of 20 logins, all other times it works fine. Does anyone know why this might be happening? Thanks

It seems to be related to file based sessions.

Consider using DB based sessions and see if you get the errors.

(This post was last modified: 07-28-2016, 08:52 AM by PaulD. Edit Reason: Added PS )

I must admit I had a similar error appear erratically for a while, although it seems to have stopped now. I never found the source of it and was using db sessions. At the time I put it down to either the files I was working on not being fully saved when I tried to load the page, or on my own programming errors, or my own hosting connection to the database. However, have not seen it again for some time but as I said, I never found the source of the error. As soon as I reloaded the page it went away again.

This does not provide any additional info but just to confirm I have seen this error too.

Best wishes,


PS So after writing this I went back to my site and logged in only to get the error again! This surprised me as I had not seen it before so I decided to try to replicate it. I thought it had something to do with my authorization and login processes perhaps trying to write to a record that didn't yet exist. So I emptied the session table, and tried to login, no problems. But the session was not in the database. I discovered that somehow I must have overwritten a config file that meant I was using files for my sessions, not the database. I fixed that and have not had the issue since. So perhaps it is because the 'sess_save_path' is not set with file storage (as was with the case with me) but if it is not set with the database you get a definite error as table cannot be found.
So to OP, have you set the sess_save_path in the config file? That might help.

Thanks for the replies! Very interesting. I havent used DB sessions before and dont know too much about it yet but I will check into it too and try to keep this thread updated with what I find out with my app. Thanks again and if anyone has any new information please keep me updated too

Also I just noticed that every now and then it will give me the error "email/username is required" even though I made sure to submit the correct email address

Theme © iAndrew 2016 - Forum software by © MyBB