• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[split] Debug toolbar? <CI4 is under development?>

#1
Docs says *The Debug Toolbar is still under construction with several planned features not yet implemented.* and I am very aware of it.
Recently I set up Vagrant virtualbox environment to try out PHP7 and CI4. I am facing wrong time measure in debug bar. It is $totalTime variable from file 'system/Debug/Toolbar/View/toolbar.tpl.php' ln. 13. It is showing period that is ~100x shorter than real req->res time. For example there is written 2ms and when I check extended list of partial req/res tasks it is ~200 ms and every time variable shows ~100x lesser value than real time spending was. It is the same for {elapsed_time} at the bottom of the welcome_message.php view file but I suppose it is the same value pulled from same variable (although I didn't explore all of the code yet). Image to easier understanding what I am talking about:

[Image: SdLuY6o.png]

In debug bar and at the bottom it is said 1ms but it is clearly pointed that only Bootstrap takes 64ms and so on.
Reply

#2
I'm a little confused Smile

Your image doesn't show anything out of whack. At the bottom of the page it shows the rendered time as 0.001 seconds, which is 1 millisecond. The displayed time in the Toolbar is 1ms. Those two match so far. The times that are being shown in the Timeline, like the Bootstrap time, is 0.64 milliseconds, not 64 milliseconds like you stated at the end of your post. Less than 1 millisecond. So - all of those times on the page work together and make sense as far as I can tell.

If you're seeing a 100x difference between what the browser shows in the developer tools then what the Toolbar is showing, then we definitely have something to explore. But you're not showing that.
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#3
Wait! Now, I am confused.
It is really 1ms per request?
It was took as common by me that 200ms or 90ms is fair time for loading.
I totally overlooked the fact something is less than 1ms.

Pebkac happened. Now is ok.  Blush
Reply

#4
No worries. Smile

With PHP7 and the Object Cache on, yes, you'll see 1ms page loads on simple pages like this. With Object Cache off, under a non-optimized Apache, I'm currently seeing around 15ms page loads for the welcome page. Under an optimized NGINX install, I've seen this page as low as 3ms-5ms.

So, speed seems to be close to CI3 speeds currently.
Support Development  • Practical CodeIgniter 3  • Vulcan - CLI Tools for CI4
Reply

#5
On my Windows 10 system using Xampp with php7 and OpCache on I' am getting Page rendered in 0.004 seconds.

This is using a base Controller with Admin and FrontController, Home extends FontController.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.