• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved] allow query string (?p=) to one directory only

#1
Hello CI'ers,
I'm trying to embed a forum app into a codeigniter page. The problem I am running into is that the app is producing tradition query string calls which CI is not allowing.. ie. I get a 404.

When I (globally) allow traditional query strings in config.php:

$config['enable_query_strings'] = TRUE;

The site doesn't work.

I then tried overriding the config in just the forum controller itself:

$this->config->set_item('enable_query_strings', TRUE);

That did not work.

Any ideas?
Reply

#2
FYI, this is an example of a call that is generated by the app that returns a 404:
http://domain.com/daforum/index.php?p=/&...%2F&locale=

The same call without the query string:
http://domain.com/daforum/index.php

Works fine.
Reply

#3
Strange thing.. if I change one character of that first URL, it works fine.. it's the '&' char. before 'remote':

domain.com/daforum/index.php?p=/?remote=http%3A%2F%2Fdomain.com%2Fforum%2F&locale=

I then tried allowing '&' characters via the config.php as such:
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\&\=\-';

This did not work.
Reply

#4
I solved this in config.php by doing:
$config['enable_query_strings'] = FALSE;

and
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\&\=\-';

Then editing the .htaccess file for the app that was sending the query string call... seems to work.

Donovan
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2017 MyBB Group.