• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Email library produces weird error while sending mails

I'm having the same problem. I had it working great and on Friday it started throwing the following error:

"A PHP Error was encountered
Severity: Notice
Message: fwrite() [function.fwrite]: send of 3293 bytes failed with errno=32 Broken pipe
Filename: libraries/Email.php
Line Number: 1816"

I've tried all the suggestions from above. I even took the time to 60 instead of 30. 

BlueHost says all my configurations look good on their end. They even did a PHP Mail script from the website to make sure it was working and it is. 

Any suggestions?

Digging up old thread as its still not resolved (i'm getting this as we getting rate limited now)

The problem is when the ISP disconnected you after accepting the connection (spam checking, rate limiting on from/to address etc).

The send_data command don't check if the $this->_smtp_connect is still active with each sending of the command, so if ISP drops connection in middle of transmitting, then fwrite throw an uncaught error.

I will when I have time again if I can add a check if "$this->_smtp_connect" is still active before trying to send data and catch error from fwrite gracefully. Just bit swamped.

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.