• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot set max execution time limit due to system policy [was CI 2.x!?]

#1
Hello, 
first sorry for my bad English...  Blush
Then ! I worked today without internet, so i made some changes on a few controllers and models. When i uploaded these files, i got a blank page. So i tried to find where was the bug, but ... did not found ! I looked in my logs, and got this : 

ERROR - 2017-10-01 23:44:48 --> Severity: Warning  --> set_time_limit(): Cannot set max execution time limit due to system policy 

I tried to search on Google but ... Nothing.  Confused
So you're my last hope ! Can someone help me ?

Thank you !
Reply

#2
Try removing the line with set_time_limit() or comment it out.
I dont think that CI will set a time limit so I presume its something you added.

But with out a bit of code from you its impossible to say.
On the package it said needs Windows 7 or better. So I installed Linux.
Reply

#3
Looks to me like you don't have any permission to change the settings for "set_time_limit()". This should be a PHP setting "php.ini" the function is i guess disabled to be used.

Is this on a local machine or Shared Hosting or own server (VPS, Dedicated)?
Reply

#4
I do not use set_time_limit()... That's why I don't understand why i got this error. I know on which file the bug is. Fortunately, I found an old save of this file, so I uploaded it back and my website is working.
I'll check the file and try to find where the bug is to tell you.

It's on a shared hosting.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.