• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[split] Bug in new form validation?

#11
https://github.com/bcit-ci/CodeIgniter/c...33501d4fa6

But we already have the first case of ICU <4.6 on PHP 7.2: https://forum.codeigniter.com/thread-69813.html
Reply

#12
I have tested the solution on a problematic server and it seems to be working. Thank you.
Reply

#13
Works fine for me too
Reply

#14
I had to make this change on line 1859 of system/libraries/Email.php in order for the above solution to work for me.
Reply

#15
The above solution solved this issue also on PHP 5.6. Thanks!
Reply

#16
Solved the initial issue, however there still exists the subsequent deprecation error.

Versions:
Quote:PHP Version 7.2.2
intl version 1.1.0
ICU version 4.2.1
ICU TZData version 2009j
ICU Unicode version 5.1


Error:
Quote:A PHP Error was encountered
Severity: 8192
Message: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated
Filename: libraries/Form_validation.php
Line Number: 1237
Backtrace:
File: /home/mysite/public_html/application/controllers/User.php
Line: 32
Function: run

File: /home/mysite/public_html/index.php
Line: 315
Function: require_once
Reply

#17
Just a NOTE:

The users editing and modifying the ./system files should not be doing that
you should extend the Libraries.
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#18
(02-13-2018, 07:22 PM)BilltheCat Wrote: Solved the initial issue, however there still exists the subsequent deprecation error.

Versions:
Quote:PHP Version 7.2.2
intl version 1.1.0
ICU version 4.2.1
ICU TZData version 2009j
ICU Unicode version 5.1


Error:
Quote:A PHP Error was encountered
Severity: 8192
Message: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated
Filename: libraries/Form_validation.php
Line Number: 1237
Backtrace:
File: /home/mysite/public_html/application/controllers/User.php
Line: 32
Function: run

File: /home/mysite/public_html/index.php
Line: 315
Function: require_once

Yes, that can't be resolved by CI.

INTL_IDNA_VARIANT_2003 is deprecated since PHP 7.2, but is the only option available if you don't have ICU 4.6+ ... this was already mentioned in the thread.

Upgrade ICU.
Reply

#19
(02-14-2018, 04:58 AM)InsiteFX Wrote: Just a NOTE:

The users editing and modifying the ./system files should not be doing that
you should extend the Libraries.

So that they forget to remove the extensions on the next upgrade, and have a permanent override, possibly preventing them from receiving other bugfixes?

It's fine to apply temporary patches that come from the upstream.
Reply

#20
(02-14-2018, 11:22 AM)Narf Wrote:
(02-13-2018, 07:22 PM)BilltheCat Wrote: Solved the initial issue, however there still exists the subsequent deprecation error.

Versions:
Quote:PHP Version 7.2.2
intl version 1.1.0
ICU version 4.2.1
ICU TZData version 2009j
ICU Unicode version 5.1


Error:
Quote:A PHP Error was encountered
Severity: 8192
Message: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated
Filename: libraries/Form_validation.php
Line Number: 1237
Backtrace:
File: /home/mysite/public_html/application/controllers/User.php
Line: 32
Function: run

File: /home/mysite/public_html/index.php
Line: 315
Function: require_once

Yes, that can't be resolved by CI.

INTL_IDNA_VARIANT_2003 is deprecated since PHP 7.2, but is the only option available if you don't have ICU 4.6+ ... this was already mentioned in the thread.

Upgrade ICU.

I get that CI can't solve it, but my point is that this IS the current version of ICU for CentOS 6.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.