• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CI 3.X Session Core problems

#1
Brick 
My program occasionally appears with the following error:
Fatal error: Class CI_Session_files_driver contains 5 abstract method and must therefore be declared abstract or implement the remaining methods.
[Image: 1523595699WechatIMG176.jpeg]

My configuration file is as follows:
[Image: 1523595699WechatIMG175.jpeg]

I've been searching the internet for a long time and I can't find a solution.But I go to the CI of the following system/libraries/Session/drivers found the problem。

This is Session_driver.php
[Image: 1523596189WechatIMG177.jpeg]

this is Session_files_driver.php
[Image: 1523596189WechatIMG178.jpeg]

Why implement this interface twice?I felt this would be a fatal error.I think that's why I've got a fatal error in my project.

May I ask a CI developer to tell me why? Thank you.
Reply

#2
Having both classes declare that they implement the same interface can be construed as being explicit. It is *not* any sort of fatal error.

Read the error message: PHP cannot find your error view files.

It looks more likely that you upgraded from CI2 to CI3 without updating your application folder. CI2 had application/errors, whereas CI3 has application/views/errors.
Reply

#3
https://forum.codeigniter.com/thread-64849.html

Please don't post screenshots; copy-pasting text is more than fine.
Reply

#4
(04-13-2018, 01:15 AM)ciadmin Wrote: Having both classes declare that they implement the same interface can be construed as being explicit. It is *not* any sort of fatal error.

Read the error message: PHP cannot find your error view files.

It looks more likely that you upgraded from CI2 to CI3 without updating your application folder. CI2 had application/errors, whereas CI3 has application/views/errors.

I feel like you're right, but I'm upgrading from 3.1.0 to 3.1.8, I don't think you're saying that.
Reply

#5
(04-13-2018, 01:20 AM)Narf Wrote: https://forum.codeigniter.com/thread-64849.html

Please don't post screenshots; copy-pasting text is more than fine.

Narf, I run WAMPServer3.1 on the windows2008 R2 as the working environment, now has been in the error, what method to solve it, with NGINX+MYSQL+PHP7 can be resolved?
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.